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KZoom is a KDE handy tool for magnifing portion of screen. Various zooming controls along
with easy of use make it suitable both for professionals in webdesign and distractive toy for rest
of us. This document describe version 0.5.
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Chapter 1. Introduction

This is KZoom users manual. Sometime need arise for enlarging screen portion to look more
closely at some picture, web page or application interface. And more than that to view enlarged
screen portions which change in realtime. For first situation it's need by imaging programs like
KSnapshots or Gimp. But tracking realtime changing screen at enlarged sizes can be done with
KZoom like utilities.

KZoom feature 16 zoom levels very easy to change them, panning zooming rectangle, moving
and resizing zoomed area, changing refresh rate and many other features. User interface very
simple and intuitive, while professionals can adjust many parameters with precision. Almost all
functional parameters are preserved and that way KZoom restore previous state when is
restarted.
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KZoom view on the KDE desktop

Chapter 2. Using KZoom

KZoom have to main concepts: the screen area to zoom and the view of zoomed area. Most of
the time rectangular area on screen which need to be zoomed is not marked, but KZoom main
window is visible and you can figure where zoomed rectangular area is.

Rectangular zoomed area

This is that portion of screen which KZoom will zoom it and show it in view window. Zoomed
area is identified by top-left corner coordinate, width and height. Dimensions are in pixels.
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To satisfy needs for precisions we can view and adjust these paramateres directly from control
toolbar which hold 4 spinboxes: X, Y, Width and Height. The're some situations when is not
evident where zoom are is located on screen. Here com handy Show Zoom Area toggle button
on main toolbar. When you activate it, an rectangle is draw on screen marking zoomed area.
This action can be performed selecting View->Show Zoom Area from menu or pressing F6 key.

View area

KZoom main window show rectangular screen magnified by selected zoom factor. If zooming
some screen part will go to large dimensions, then view area will cut that zoomed screen part.
To view more, redimension KZoom window.
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Changing zoom factor directly is performed in two ways: select appropriate item fromView-
>Zoom menu or select it from main toolbar combobox. For convenience you can incrementaly
change it up or down pressing Zoom In or Zoom Out main toolbar buttons or activating shortcut
keys: Ctrl+Shift++ and respective Ctrl+-

Changing what screen part is zoomed

Two operations are needed to change zoomed area: moving and resizing. The main methods
to change position and dimensions are by mouse or using control bar spinboxes. While using
mouse is more convenient in day to day work, when you're forced to have precission to make



zoomed screen captures spinboxes controled values are a must.

Move operation can be performed easily in two ways. The adictive one is to pan view area
dragging it with mouse. That is, click on KZoom main window zoom area and start dragging. As
much you hold mouse button pressed, an rectangle will follow zoomed area when you move
mouse. After releasing mouse button it will disappear. The second move method is to press on
Move Zoom Area button on main toolbar or press F7 key. Mouse cursor will change in a cross
with arrows. Press anywhere on screen and hold the mouse button. Mouse cursor will jump to
zoom rectangle area and zoom rectangle will show up. Start moving zoom area where you
want. When finished release mouse button.

Resize is in fact a move and resize operation which you made on one step. To enter in resize
mode press on Resize Zoom Area button on main toolbar or press F8 key. Mouse cursor will
change in a cross hair form. Move mouse cursor where you want top-left zoom area corner and
press mouse button. While holding down mouse cursor start dragging. An growing rectangle will
show up. After you're happy with rectangle size release mouse button.

Both when move or resize zoom area you can observe main toolbar spinboxes values changing
and KZoom main window zoomed area is updated. This way you have visual control on what
zoomed and what position and/or dimensions zoom area have.

Aditional operations

To further control zoom actions, main toolbar have aditional buttons. Ones of them you already
encountered in previous section. Zoomed area is by default continous updated. To control
update rate change value in Refresh spinbox. Make this value higher if you machine have low
resources and mouse is moving slowly when KZoom is running. To take a snapshot for some
changing portion of screen, deactivate Continous Update toggle button from main toolbar.

There are many times when you want to save zoomed screen area. You have two options:
save to file or print it. Choose File->Save from menu or press Save button from main toolbar.
Currently you can save zoomed image as PNG, JPEG or XPM image formats. To print zoomed
area choose File->Print... from menu or press Print button from main toolbar. Printing include
informations about zoom factor, rectangle position and dimensions and date when printing was
done. Image is automatically cut to fit in page. Please consider printing as landscape if you
want to preserve more zoomed area and width value is large than height.

Note

Printed or saved image is what you see in KZoom view area. If you want to save
more and zoom factor determine that enlarged screen portion is too big for
KZoom window size, then resize window to large values.

Chapter 3. Command Reference

The Menubar
The File Menu
Eile->Save (Ctrl+S)

Save current zoomed area as image file. You can choose image format by filename
extension.



FEile->Print... (Ctrl+P)

Print current zoomed area in a pretty print format. Zoom rectangle coordinates, zoom
factor and date are informations printed along with image.

File->Quit (Ctrl+Q)
Exit KZoom.
The View Menu
View->Zoom In (Ctrl+Shift++)
Enlarge zoomed area by one unit.
View->Zoom Qut (Ctrl+-)
Shrink zoomed area by one unit.
View->Zoom
Open submenu with zoom factors list. Select a zoom factor to chage current one.
View->Continuos Update (F5)
Toggle on/off continuos updating of zoomed area. Most of the time you want this turned
on. When some hard to reproduce screen event occur, you can imortalize by pressing F5
or selecting this menu item.
View->Show Zoom Area (F6)

Toggle on/off zooming rectangle area displaying. Turn on this function when you're lost
and don't figure what screen portion is zoomed.

View->Move Zoom Area (F7)

Enter in zoom area moving mode. Click anywhere on screen and start dragging. When
you're finished release mouse button.

View->Resize Zoom Area (F8)
Enter in zoom area resizing mode. Move mouse where you want zoom area top-left

corner. Click and start dragging. When you're happy with zoom rectangle dimesions
release mouse button.

The Settings Menu
Settings->Show Toolbar

Toogle on/off main toolbar displaying.
Settings->Show Cntrol Bar

Toogle on/off zoom control toolbar displaying.



Settings->Show Statusbar
Toogle on/off status bar displaying.
Settings->Show Menubar (Ctrl+M)
Toogle on/off menu bar displaying.
Settings->Configure Key Bindings...

Open key bindings configuration dialog. Here you can redefine KZoom application
shortcuts if defaults ones don't feet your needs.

Settings->Configure Toolbars...

Open toolbars configuration dialog. Here you can rearange KZoom toolbars buttons if
default settings don't feet your needs.

Settings->Save Settings

Save KZoom settings imediately. Note that when you exit KZoom settings will be
preserved even you not saved them explicitely.

The Help Menu
Help->Contents (F1)

Open KZoom documentation main page.
Help+What's This? (Shift+F1)

Mouse cursor change into question mark and you can click on KZoom window parts to
obtain more informations about buttons or actions.

Help->Report Bug...

Open bug reporting dialog for KZoom. Very usefull to send feature requests and, of
course, bug reports.

Help+About KZoom

Open information window about KZoom displaying application version, authors and
contributors list and license file.

Help+About KDE

Open information window about KDE project displaying current version and contact
information.

The Toolbar

The Main Toolbar
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Save current zoomed area as image file. You can choose image format by filename
extension.
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Print current zoomed area in a pretty print format. Zoom rectangle coordinates, zoom
factor and date are informations printed along with image.

Enlarge zoomed area by one unit.
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Shrink zoomed area by one unit.
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Open drop-down box with zoom factors list. Select a zoom factor to chage current one.

Refresh: |1 o EEIms

Enter here time interval for zoom area update. Values are in miliseconds and cannot be
under 50 ms to prevent resource exhausting.
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Toggle on/off continuos updating of zoomed area. Most of the time you want this turned
on. When some hard to reproduce screen event occur, you can imortalize by pressing F5
or selecting this menu item.
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Toggle on/off zooming rectangle area displaying. Turn on this function when you're lost
and don't figure what screen portion is zoomed.

Enter in zoom area moving mode. Click anywhere on screen and start dragging. When
you're finished release mouse button.
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Enter in zoom area resizing mode. Move mouse where you want zoom area top-left
corner. Click and start dragging. When you're happy with zoom rectangle dimesions
release mouse button.

The Control Toolbar
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Set X coordinate for zoom rectangle top-left corner. The (0,0) point is located in top-left
screen corner.
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Set Y coordinate for zoom rectangle top-left corner. The (0,0) point is located in top-left
screen corner.

Width: |1 63 EEI

Set zoom rectangle width.

Height: I'I 12 EEI

Set zoom rectangle height.

Chapter 4. Questions and Answers

4.1. Why mouse start to move too slowly?
4.2. In some situations zoomed rectangle leave trails on screen. Why?

4.1. Why mouse start to move too slowly?

The bigger resolution is and the bigger zoomed area is, more computing power is needed.
Specialy for magnifing operation. When refresh rate is very high, CPU is used very hard
and when mouse move over KZoom window slowness can be present. Try to use zoom
and refresh values not too stressing if your computer is limited in resources.

4.2. In some situations zoomed rectangle leave trails on screen. Why?

Zoomed rectangle drawing method is very simple. Because of this you can notice some
flashings when is redrawed. It is possible that screen repainting enter in conflict with
rectangle drawing resulting in image on screen to not be corectly updated. There is no
harm. Screen will be cleaned when you force that portion to by repainted: i.e. move any
window over that area. | hope to find another mode to draw rectangle.

Chapter 5. Credits and License
KZoom
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This documentation is licensed under the terms of the GNU Free Documentation License.

This program is licensed under the terms of the GNU General Public License.

Appendix A. Installation

How to obtain KZoom

KZoom web site is hosted on SourceForge servers and can be reached at:
http://www.ro.kde.org/kzoom/



Source code and bhinaries distributions can be downloaded from:
http://www.ro.kde.org/kzoom/download.html

Requirements

It can be compiled on any platform where KDE and Qt have been ported. You should have at
least KDE 3.0 and Qt 3.0

You need to have GNU C++ compiler and associated tools. To regenerate the user
documentation you need to have meinproc.

Compilation and installation

Compile and install with the usual:

% ./ configure
% make
% nake install

Last command must be run as root user.



